Frequently asked questions (FAQ)

What are the technical requirements for using blogigo?

To be able to use blogigo you will need an Internet connection and a browser. We recommend that you use either Microsoft Internet Explorer Version 5.5 or higher or Mozilla Version 1.3 or higher. These browsers support the Design-WYSIWYG Editor for easy formatting of your weblog entries.

For some features it will also be required, that your browser enables cookies and JavaScript execution.